Back to overview
Maintenance

Security maintenance over sCloud Dashboard

May 9, 2026 at 12:00am UTC  –  May 9, 2026 at 1:20am UTC
Affected services
sCloud Website & Dashboard

Resolved
May 9, 2026 at 1:20am UTC

Maintenance ended

Updated
May 9, 2026 at 1:20am UTC

Maintenance is over, thanks for your patience.

Created
May 9, 2026 at 12:00am UTC

sCloud Dashboard is currently unavailable for a security maintenance. We apologize for any inconvenience and are working on bringing the Dashboard online as quickly as possible.